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Remember: following good accessibility practices in document creation saves significant time and effort in maintaining accessible material.
[bookmark: _Toc167349110]Microsoft Office 365
The Microsoft Office suite is largely the same for the menus used for adding the various needed elements for accessibility.  Individual program requirements are marked separately for convenience.
[bookmark: _Toc167349111]Applying Heading Styles
Headings are used as navigational landmarks by assistive technology.  It is important to use the style presets to create these landmarks; the presets are in the fourth group of the Home ribbon.
[image: ]
Select the preferred style.  Once applied, the look can be changed as desired.  If you will be using the heading multiple times and want to keep the look, it can be saved by clicking the “More Styles” button under the down arrow of the scroll bar of the Styles group and selecting “Create A Style.”  That opens a new dialog window.  Click the Modify button to look at all the options.
First Dialog Window
[image: ]
Modify Style Options
[image: ]
In this menu, you can change the name, type (what it applies to), what it is based on (the style for the selected text), and the next paragraph’s style (what type follows it).  The “Style based on:” option will apply the desired tag (paragraph, heading 1, heading 2, etc).  Unless you want a specific option to follow it, the style for the following paragraph can remain “Normal.”  Make sure to check the “Add to the Styles gallery” checkbox to add it to the window on the ribbon.
To check your heading structure, go to the View ribbon and select the Navigation Pane checkbox, which is the third option in the second group.  The Headings tab of this pane will show you all the existing headings in the document and how they are nested.  
For Excel, styles applied will act in the same way.  Freezing a row will not cause the cell to act as a heading for its assigned column or row.
[bookmark: _Toc167349112]Reading Order
Reading order is largely determined by the language chosen for Microsoft Office.  The heading structure will also assist with determining the reading order.  The important things to note are images that are not in-line with text and if the document layout is altered, such as a multi-column layout.
An image’s placement in a document can be determined from either the Layout Options button that appears when an image is selected or from the Position Object button on the Format ribbon, found after Picture layout.  The default is “In-line with text” which is preferable since it means assistive technology will find it directly after whatever is placed before it.  If another option is selected from the “With Text Wrapping” options, there is a chance that assistive technology will not understand its position in relation to other elements in the document.  Fixing its position, the second checkbox from the Layout Options menu, may help with this but is not guaranteed.
[bookmark: _Toc167349113]Adding Alt Text
Alt text was previously added from the Format Picture menu.  It now has its own menu item.  When an image is added to a document, Office 365 may generate automated alt text if the setting is enabled.  If so, Approve and Edit buttons will appear on the image.  Generally, automated alt text is very simple and likely will not sufficiently describe the image.  
[image: Image in Word with overlay at the bottom with automated alt text: A cup of coffee. 2 buttons for Approve and Edit]
Clicking Edit will open the Alt Text panel on the right where new alt text can be added or the image marked as “decorative”. Decorative images are skipped by assistive technology when reading (not during editing); this is best practice for images used for visually attracting attention or dividing sections.  If the image is not adding value to the context, it should be marked decorative.
The alt text panel can also be opened from the Check Accessibility button on the Review ribbon or via the context menu (right click).    
Please visit W3C’s Alt Text decision tree for a simple guide on what to put as alternate text.  
[bookmark: _Toc167349114]Table Headings and Alt Text
Tables use a separate form of heading: header row.  This allows a screen reader or other assistive technology to read a data cell and the heading together to easily explain info relationships to the user.
To apply a heading, draw a table and select the Design ribbon that appears while the table is selected.  The first checkbox, header row, will make the first row headings.  First column, the fourth checkbox, will apply the same heading structure to the first column.  Please note that merged cells or complex tables will make this difficult to interpret, so be wary before choosing to use one of these options.  If you are using more complex tables, Excel is better able to interpret this information.
[image: ]
You should also open the Table Properties menu by going to the Layout ribbon and select the third button, Properties.  Alternatively, select the table and bring up the context menu and select Table Properties, which will be the second to last option.  From here, go to the Row tab (second option) and check the box stating, “split header rows across pages”.  This will keep the header row active if a table is pushed across pages due to edits or size.  It is also possible to add alt text to a table from this menu.  Alt text will be the fifth tab.  It functions the same manner as image alt text.  Table alt text is useful for communicating the purpose or subject of the table, typically its title.  Please note you can use the other tabs to apply the header rows and columns as well.
[image: ]
Excel Best Practices
The above practices are applicable in Excel but the program features a few additional practices that are beneficial for those with disabilities.  Conditional formatting, such as the heading cells, is useful for defining cell behaviors.  However, it is generally necessary to alter the text color of several of the formatting choices, such as the bad or good cells, since they use similar colors for text and background.  
Hide unnecessary rows and columns to aid navigation for keyboard and screen reader users and users with reading disabilities.  This avoids potential issues of accidentally moving to the far ends of a default sheet.  To do so, select the range of empty columns or rows, open the context menu, and click “hide” which is the second to last option.  The hide and unhide options are also available from the Format dropdown in the Cells grouping on the Home ribbon.

[image: Columns A through D are selected and the Hide option in the context menu is highlighted]
Formatting sheets as tables using the “Format as Table” button on the Home ribbon is the best option for screen reader users.  This enables full table navigation and behavior for screen readers.  It is especially useful for sheets with multiple tables on display as it allows a user to quickly jump between them.  Please note that it will use the default language to determine reading order so set up your tables in such a way that the reader will navigate between them how you intend (i.e. don’t put your first table two rows below the top of the second table to its right).  Most of the default table styles are acceptable but always be wary of color contrast issues.  
For sheets that require users to move between certain points to fill in data, add comments in those cells to direct users to the correct positions.  Comments are also useful for explaining directions or other requirements to help users avoid misplacing information or getting lost.  
[bookmark: _Toc167349115]PowerPoint Specifics
In older versions of PowerPoint, reading order is inverse.  Order is determined by the Selection Pane, available from the Select button on the Home Ribbon, in the Editing group.  Objects are read from bottom to top in the displayed list.  PowerPoint informs of you of this in both the Selection Pane and the Accessibility Checker.  
[image: ]
Office 365 offers a specific Reading Order panel, available on the Accessibility ribbon.  The panel will display a numbered list that will show the current reading order.  Please note that like the Selection Pane in previous versions of PowerPoint, the Reading Order panel can affect the visual layout of elements.  If an element is overlapping, the top one in the reading order will appear below it.  You may need to get creative or mark elements as decorative in order to get both the correct reading order and the visual style you desire.  PowerPoint’s default slide layouts will usually have the appropriate reading order but adding extra elements will require manual adjustment.  

[image: Accessibility ribbon with Reading Order Panel button in focus.  The Panel is open on the right.]
Previous versions of PowerPoint will place new elements at the bottom of the selection pane.  Be aware that this also can affect visual presentation since this “layers” elements over top of each other.  It may be necessary to group elements together or use another program to make them a single entity to avoid reading order issues.
Versions of Microsoft Office before 365 does not have the ability to mark images as decorative.  PowerPoint does have the ability to place elements in the background though so if you are using an image that does not add content and instead gives visual appeal or draws attention, it will be more useful to place in the background.  To do this, go to the Design Ribbon and click the Format Background button that is the last control on the ribbon.  The panel will open on the right side.
Design Ribbon and Format Background Panel
[image: ]
Using this, you can add images and other elements to background.  It will only be applied to the current slide unless you click the Apply to All button at the bottom of the panel.
AT users may rely on titles to move quickly from slide to slide.  The Accessibility Checker, explained next in this document, will warn of this.  Titles can only be applied via the layout options.  If you download a document made in Google Slides, it may not properly apply titles.  You will need to reapply the desired layout and alter the existing title to fit the desired look.  
[bookmark: _Toc167349116]Accessibility Checker
The Accessibility Checker is available from the Files Menu, Info Tab.  The second button, Inspect Document, has the Accessibility checker as its second option.  It can also be opened by using the Help search box available on the ribbons row.  Please note Publisher does not have this feature. Publisher documents will need to be remediated after exporting to PDF.
The Check Accessibility option is also available from the Review ribbon.  It is the sixth option on the ribbon and Office’s accessibility tools are available from the dropdown.
[image: The Info tab is after "Get Add-ins". Inspect Document is the second button in the main region and has a dropdown.  Check Accessibility is the second option.]
[image: The open dropdown of the Check Accessibility button.  Options are Check, Alt Text, Navigation Pane, Focus, and Options: Accessibility]
Office 365 offers continuous scanning.  The Accessibility check will appear on the lower ribbon, after the page number, word count, and other settings.  Consider enabling this if it is not already to keep aware of your document’s accessibility.  It will display “Investigate” if a potential issue is detected and “Good to go” if it believes there are no errors.  Remember to still manually check your document as the accessibility checker cannot judge the quality of alt text or reading order, only its presence.
[image: Left side of ribbon displaying Page Number, Word Count, Text Predictions, Macro Recording, and Accessibility.]
[bookmark: _Accessible_PDF_Export][bookmark: _Toc167349117]Accessible PDF Export
When saving an Office document to PDF, it is possible to export headings and other accessibility work done.  From the Save As Adobe PDF menu, on the File Save Location dialog, select “Options” from the bottom three buttons.  The Acrobat PDFMaker dialog will open.  The third checkbox, “Enable Accessibility and Reflow with tagged Adobe PDF,” must be checked.  If this is not checked, any work done to make an Office document accessible will not be exported.
[image: ]
[bookmark: _Toc167349118]

Adobe Acrobat PDF
Adobe Acrobat allows for more direct management of reading order and element description but requires more labor.  Please note that in order to edit accessibility features, the paid version Acrobat Pro is necessary.  Acrobat reader is able to interpret tagged PDFs correctly but is not able to alter tags or alt text. NOTE: There are some other programs available to do similar work (Commonlook, Foxit, etc) but they will largely follow the same process.
[bookmark: _Toc167349119]Accessibility Checker
All of the tools needed for making an accessible PDF are available from the “Prepare for accessibility” tool, available from the All Tools panel.  Adobe’s accessibility checker (“check for accessibility”) will open a dialog:
[image: Adobe Accessibility Checker options dialog]
The first option, “Create accessibility report”, saves a separate copy of the check.  By default, 31 of the 32 checks are ran; the only exception is “table summary”.  It is advised to start with these default settings and only remove checks if continual false positives occur.  Once the checker has run, it will display the results in the right side panel.

[image: Test document with the accessibility checker open. There are 3 document issues and 1 alternate text issue.]
Found issues are bolded.  Please note that Logical Reading Order and Color Contrast will always state “needs manual check” as the automated tool is not capable of making this judgement.  Each rule has a link to its explanation in the context menu.  Document issues may have a “Fix” option will open the relevant dialog.  Content types, such as alternate text or tables, will instead list the elements that require remediation.  
[bookmark: _Toc167349120]Tagging a Document
If a PDF is not tagged, assistive technology will be unable to communicate it to users.  To quickly check if a document is tagged, open the File>Properties menu (CTRL+D).  Under the Advanced group, it will state Tagged PDF: Yes/No at the bottom.  Alternatively, it is one of the criteria brought up when an accessibility check is run on the document.
To tag a document, the first step is to use the Autotag Document button that is the first option available on the Accessibility Tools panel.  This will run through the document and apply tags based on Adobe’s interpretation.  Note that it may not correctly interpret overlapping elements or more complex parts such as tables and charts.  
The tag structure can be viewed from the Tags view on the right sidebar.  Tags are very similar in format to HTML.  The Reading Order view is a more direct method of determining how elements are interpreted and in what order.  The Reading Order tool, the last option in the Accessibility Tools panel, also displays the reading order and allows you to change assignments or select content that was not tagged and determine its type.  
[image: View of a test document with the Reading Order panel and dialog open.  Elements in the document have grey bounding boxes with ordered numbers.]
[bookmark: _Toc167349121]Reading Order
The Reading Order dialog and Reading Order view will display selection boxes around tagged elements along with a number.  These numbers reflect the current reading order.  The right sidebar view also shows this list.  You can change the order by simply clicking and dragging list items to the desired location.  
If an element is not highlighted by a selection box, draw a box around the desired element with the cursor while the Reading Order dialog is open.  Selected elements will be highlighted in a pink box.  It can be somewhat difficult to select separate elements that are close together.  It usually requires a user to select some space around the desired element. You can also hold SHIFT to add additional selections to the initial one or CTRL to remove selections from the group.  After highlighting the element, choose one of the options on the dialog to assign a tag.  For reference, Acrobat calls images “figures.”  If there is an element tagged that should be hidden, such as a background picture, the Background/Artifact option will hide it.  There is no option for tagging lists; this will need to be done via the Tag structure.
After completing the desired reading order, click the Reading Options button from the Accessibility Tools panel.  This will open a dialog to determine what assistive technology uses to determine the reading order.  The document’s set reading order should be selected.
[bookmark: _Toc167349122]PDF Alt Text
Image/figure alt text is added by clicking the Set Alternate Text option from the Accessibility Tools panel.  It is vital that all images in the document be tagged via reading order prior to this step. This option opens a new dialog:
[image: ]
Acrobat will list and highlight all the images in the document.  Move through each image and add alternate text or check the “Decorative figure” checkbox if the element is not meaningful.  After all images have alternate text or marked decorative, click Save & Close.
Please visit W3C’s Alt Text decision tree for a simple guide on what to put as alternate text.  
[bookmark: _Toc167349123]Form Fields
Form Field labels are created while creating a form.  After drawing a field or using an existing field generated by Acrobat, double click it to open the Field Properties dialog.  Both the Name and Tooltip fields should contain the exact same label.  This is to ensure maximum capability with assistive technology.
[image: ]
For radio buttons, the name and tooltip determines the group; the Options tab has the individual choice names.  Dropdown and select lists use the same tab to add different choices.
Once all form fields are created and labeled, go back to the Accessibility Tools panel.  You will need to Identify and AutoTag form fields to make sure they are part of the reading order.  Alternatively, you can use the manual tagging method as well.  Helpful tip: select the visible label along with the field while assigning reading order; this will put the field into the order in the proper place.  Not doing so will probably put all of the tagged fields at the end of the reading order.  Please note that there are two reading orders with forms: the first is in the Prepare Form, where the order of the fields determines how TAB moves between them.  The second is the accessibility tools reading order which determines how the fields are found in between other elements.
[bookmark: _Toc167349124]Tag Tree Editing
Sometimes, it is necessary to edit the tag tree directly, either to fix issues or create structures the Reading Order tool can’t.  Tags are edited directly in the Tags view, available from the right sidebar.     
[image: Tag view of the test document. H1 "This is the heading 1 format" is selected.]
Tags can be edited directly by double clicking them or by selecting Properties from the ellipsis menu in the panel.  A list of PDF tags can be found here by scrolling down to the “Standard PDF tags” heading.  Tags can also be created by clicking New Tag from the ellipsis menu or the context menu.  Content is added to tags by selecting the new tag, highlighting the desired content, and clicking “Create Tag from Selection.”  
Directly editing the tag tree or reordering it (by clicking and dragging) may cause the Tag Order to be flagged by the accessibility checker.  This tends to occur if the “reading order” and the tag structure are out of alignment.  Clicking “fix” from the context menu on this error will align the reading order to the tag structure.  Most AT will use the tag tree as its basis.  

[image: Text is highlighted and the cursor is hovering "Create Tag from Selection" in the context menu.  It's the 8th option in the list.]
Some element types are easier to work with, or can only be worked with, in the tag tree.  Lists and tables are the two most common elements.  Lists are created in a similar fashion to HTML: a list (<L>) will contain “list items” (<LI>) which each hold content.  Adobe has an additional tag HTML does not: List Item Body (<LBody>).  Each list item must contain a list item body which holds the desired content.  Subpoints should be added to a new list nested into the list item.  The tree should like this:
1. <L> (list)
a) <LI> (list item)
i. <LBody> (list item body)
· First bullet point’s content
b) <LI> (second list item)
i. <LBody> (second list item body)
· Second bullet’s content
· <L> (subpoint of second bullet)
· <LI> (new list item)
· <LBody>
· Subpoint’s content
Tables in PDFs are tagged by row (<TR>).  Each row must contain the maximum number of cells for the table, even if they are blank.  This ensures proper column distribution.  Otherwise, the “table regularity” error will trip.  There are two types of cell tags: header cell (<TH>) and regular cell (<TD>).  Header cells are used to maintain the relationship between cells.  

[image: PDF table with the Tag tree showing the table with 4 rows.  The first row is expanded to show 3 header cells. ]
A properly created table will look like this:
· <Table>
· <TR> (table row)
· <TH> (header cell)
· Content
· <TH> (header cell)
· Content
· <TH> (header cell)
· Content
· <TR> (second row)
· <TD> (regular cell)
· Content
· <TD> (regular cell)
· Content
· <TD> (regular cell)
· Content
More complex tables can be created; Level Access has posted a guide for these.  In general, simpler tables are easier to both manipulate and for AT to read.  
[bookmark: _Toc167349125]

Google Workspace
Google Docs offers many of the same features as other authoring tools.  Please note that Google Docs does not have a native accessibility checker; you will need to install and run an extension.  This document will not cover any of the offered services.
Accessibility Support
Google Docs, and its other components, have accessibility support for assistive technology but it needs to be enabled.  This is done from the Tools menu > Accessibility (last option).  This opens a dialog that enables screen reader support, braille support, and collaborator announcements.  Please note this is an account setting; enabling this in your view will not enable it for other collaborators.  
Enabling this support adds an Accessibility menu to the toolbar.  It is not necessary for actually creating an accessible document but is helpful for both knowing what tools are available and for double-checking documents before sharing/downloading.  Additional support is available from a Google Help article on using a screen reader with the Google Workspace.
Gmail has a couple of different settings.  By default, keyboard shortcuts are not enabled.  They are enabled from the Settings menu, General Tab.  It is recommended to review Google’s Help Article about configuring a screen reader for use with Gmail as there is some overlap.
Google Alt Text
Google products add alt text to elements from the context menu.  Alternatively, you can press the keyboard shortcut CTRL+ALT+Y to bring up the dialog.  Simply enter your description and press Save.  
When in Gmail, alt text can be added by first selecting the image and then clicking “add alt text” from the tooltip that appears below the image.  The tooltip also offers options for resizing the image.
[image: MDTAP logo selected - tooltip offers Small, Best Fit, Original Size, Edit alt text, and Remove options.]
Reading Order
Google provides presets for headings.  You can either choose the formatting first or highlight desired text and apply the formatting.  Headings are available under Format > Paragraph Styles which will also show the keyboard shortcuts.  The text formatting can be changed and saved as a default from the same menu.  Once headings are added, the Outline panel on the left will automatically open.  The panel can be closed or opened from the View ribbon menu.  
Please note that Google Workspace does not have a native way to check other aspects of the reading order.  This is especially notable in Slides where adding elements to template slides will result in a potentially unclear reading order.  
Gmail does not have a native way to add headings or alter reading order as emails are primarily simple documents.  However, when using an outreach management tool, such as Constant Contact, it is possible to put headings and arrange reading order and Gmail will interpret them correctly.  It is best practice to make use of these tools especially for longer form emails such as newsletters.
Tables and Sheets
Google Docs tables work very similar to Word document tables.  Table Properties can be selected from the context menu of a table.  Properties will open in a right-side panel; the Row heading has a checkbox for pinning header rows.  Google Docs allows multiple rows to be selected however no columns can be selected as headings at this time.  Alternatively, a row can be pinned from the tooltip menu that appears on hover in a cell.

[image: Table in docs with the first row displaying the tooltip menu.  Table Properties is open and shows 1 header row is pinned.]
Sheets, like Excel, has the ability to set multiple columns and rows as headers.  This is done from the View Menu > Freeze.  It also has the ability to define areas as tables or insert them.  Again, doing so and marking edges of tables, empty cells, and hiding unused rows/columns is considered best practice.

Other Authoring Tools
There are several other programs that can be used to create documents and publications.  It is strongly recommended that you peruse the support section for the authoring tool you are using, such as Canva, to learn about its accessibility features and make use of them.  Regardless of the software being used, the resulting document must adhere to best practices in accessibility.  
[bookmark: _Toc167349126]Universal Accessibility Needs:
1. Heading Structure: the document must have a proper heading structure that is visually coherent and programmatically usable.  
2. Logical Reading Order: The audience should be able to follow the document in the intended order regardless of input method.
3. Alternate Text: all images and other non-text context must have an alternate description or be marked decorative.
4. Use of Color: Color should not be the sole identifier of content, such as links.  A visible distinguisher, such as a symbol or outline, must be used.
5. Color Contrast: Text must maintain a 4.5:1 ratio of color to its background.  
6. Link Purpose: Links should use phrases to identify their destination to the user.  URLs should generally be avoided unless they are easily identifiable.
a. Note: this does not apply to email addresses.
Adobe InDesign has some features for implementing accessibility but will require finishing in Adobe Acrobat.  The IT Accessibility Initiative has done a walkthrough of the process in a previous webinar.  It largely follows Adobe’s Accessible PDFs Guide.  It is common for other authoring tools to follow this same process.
Most authoring tools offer the ability to Save to PDF or other formats.  Check that the tool is capable of exporting tagged PDFs (as Word can) in order to save already completed work.  At minimum, this saves some time and effort from having to remediate an entire document.  
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